FAQ VBAConsultez toutes les FAQ

Nombre d'auteurs : 10, nombre de questions : 133, dernière mise à jour : 30 mars 2017 

 
OuvrirSommaireExcelPlagesMise en forme

Il existe deux approches. On veut encadrer le contour externe de la plage, on utilise BordersAround.

 
Sélectionnez
objRange.BorderAround xlContinuous, xlMedium, xlColorIndexAutomatic

on souhaite mettre des bordures particulières, on passe par l'élément de la collection Borders

 
Sélectionnez
Dim objWorksheet As Worksheet, objRange As Range

Set objWorksheet = ThisWorkbook.ActiveSheet
Set objRange = objWorksheet.Range(objWorksheet.Cells(1, 1), objWorksheet.Cells(10, 10))
With objRange.Borders
    With .Item(xlInsideHorizontal)
        .ColorIndex = 5
        .LineStyle = xlContinuous
        .Weight = xlThin
    End With
End With

On veut tout encadrer

 
Sélectionnez
With objRange.Borders
    .ColorIndex = 5
    .LineStyle = xlContinuous
    .Weight = xlThin
End With
Créé le 30 janvier 2004  par bidou

Le code suivant va mettre un fond vert à toutes les cellules dont la valeur est doublonnée dans la première colonne.

 
Sélectionnez
Dim ObjRange As Range

Set ObjRange = Range("A1").EntireColumn
With ObjRange.FormatConditions
    .Add Type:=xlExpression, Formula1:="=NB.SI(C1;LC)>1"
    .Item(.Count).Interior.Color = vbGreen
End With
Créé le 30 janvier 2004  par bidou

On peut ajouter un lien indifféremment à un objet ou à une plage.

 
Sélectionnez
Dim objLink As Hyperlink

Set objLink = ActiveSheet.Hyperlinks.Add(Range("F2"), "d:\user\tuto.xls")
With objLink
    .SubAddress = "A1:C10"
    .Follow NewWindow:=True
End With

Ce code crée le lien est ouvre une nouvelle fenêtre contenant la cible. Astuce : Lorsqu'on modifie la cible d'un lien existant on ne modifie pas le texte du lien. Pour que celui-ci change, il faut modifier la propriété value de la cellule contenant le lien :

 
Sélectionnez
objLink.Address = "d:\jmarc.xls"
objLink.Range.Value = "d:\jmarc.xls"
Créé le 4 février 2004  par bidou
  

Les sources présentées sur cette page sont libres de droits et vous pouvez les utiliser à votre convenance. Par contre, la page de présentation constitue une œuvre intellectuelle protégée par les droits d'auteur. Copyright © 2009 Developpez Developpez LLC. Tous droits réservés Developpez LLC. Aucune reproduction, même partielle, ne peut être faite de ce site et de l'ensemble de son contenu : textes, documents et images sans l'autorisation expresse de Developpez LLC. Sinon vous encourez selon la loi jusqu'à trois ans de prison et jusqu'à 300 000 € de dommages et intérêts.